Tag Archives: lan

Utilizar WAMP en una LAN

5 Jul

Un breve paso a paso de cómo utilizar WAMP en una LAN, de manera que todos los usuarios puedan acceder a los sitios que estemos probando.

Configuración

1. Nos aseguramos de tener las carpetas creadas para los logs. Minimamente, si vamos a tener un sitio “test” dentro de www, deberíamos tener las siguientes carpetas creadas en WAMP:
C:/wamp/www/logs
C:/wamp/www/test/logs

2. Editamos el archivo httpd.conf ubicado en algo así como: C:\wamp\bin\apache\apache2.2.8\conf
En dicho archivo, descomentamos la línea:
“Include conf/extra/httpd-vhosts.conf”

3.  Editamos el archivo httpd-vhosts.conf ubicado en algo así como C:\wamp\bin\apache\apache2.2.8\conf\extra. En dicho archivo, minimamente deberíamos tener lo siguiente (cambiar de acuerdo a los sitios que vayamos a querer compartir):

NameVirtualHost *:80
<VirtualHost *:80>
ServerName test
DocumentRoot e:/wamp/www/test
ErrorLog e:/wamp/www/test/logs/error.log
CustomLog e:/wamp/www/test/logs/access.log common
</VirtualHost>
<VirtualHost *:80>
ServerName localhost
DocumentRoot e:/wamp/www
ErrorLog e:/wamp/www/logs/error.log
CustomLog e:/wamp/www/logs/access.log common
</VirtualHost>

(Ponemos la carpeta en que tenemos los sitios subidos en www dentro de wamp)

4. En el servidor, abrir el archivo hosts dentro de C:/Windows/System32/drivers/etc. Para nuestro sitio “test”, deberíamos tener al menos lo siguiente:

127.0.0.1 localhost
127.0.0.1 test

5.  En las otras máquinas, abrimos también el archivo hosts, y deberemos tener lo siguiente:

192.168.1.107 test

Donde 192.168.1.107 es la dirección IP del servidor (la averiguamos yendo al cmd, ipconfig).

6. Hecho esto, reiniciar el WAMP, y apretar el botón de “Put Online” (de lo contrario tendremos un error 403 cuando queramos acceder de las otras máquinas de la lan).

7. Para acceder, desde el navegador ponemos: http://test.

8. En caso de problemas, verificar que el firewall esté desactivado, y la configuración del router.

Configuración del Router

1. Acceder a la pantalla del Router
2. Buscar la configuración para los “Virtual Servers”
3. Agregar una configuración HTTP donde el protocolo es TCP, el puerto privado es 80 (o en el que tengamos corriendo wamp), el público es 80, y el servidor es la dirección IP del servidor.

* En el caso que esto no funcione, verificar que el Firewall del servidor esté dejando pasar a las máquinas que se quieren conectar (o desactivarlo)

Anuncios
A %d blogueros les gusta esto: